System Outage
Incident Report for Core Practice
Resolved
Summary of Impact:
On 25th October 2023, between 11:00AM to 12:30PM (AEDT), a server outage was identified. A significant number of users encountered an "SSL Certificate Expired" warning from their browser, which inhibited their ability to access the Core Practice system.

Root Cause:
Upon investigation, the expiration of the SSL Certificate was traced back to an unsuccessful automatic renewal. The failure in automatic renewal was attributed to modifications in the validation process of approved domains by our Certificate Authority provider. While we aimed to reduce the outage duration, this incident was exacerbated when it was discovered that the certificate had not been successfully installed across multiple servers. Fortunately, we managed to utilize redundant servers on standby to meet the user demands.

Mitigation:
The Core Practice team is dedicated to improving our infrastructure to prevent such issues from recurring. We are currently incorporating Application Gateway technology to mitigate the risks tied to certificate management.
Posted Oct 25, 2023 - 16:38 AEDT
Update
We are continuing to monitor for any further issues.
Posted Oct 25, 2023 - 13:11 AEDT
Monitoring
Our system is working expected now and we will continue to monitor the issue. We sincerely apologize for the impact to affected customers.
Posted Oct 25, 2023 - 13:06 AEDT
Investigating
We are currently experiencing a system outage. Our teams are actively investigating and working on a resolution. We understand how critical our services are to your operations, and we apologize for any inconvenience this may be causing.
Posted Oct 25, 2023 - 11:34 AEDT
This incident affected: Core Practice Application.