Performance Degradation on Webset 1

Incident Report for Core Practice

Resolved

Summary
Our web application experienced performance issues on November 17, 2025 between 09:50 AM and 10:10 AM AEDT, due to elevated CPU usage caused by a surge in connection traffic. Users may have experienced slow page loads and connection timeouts during this period.

Root Cause
A surge in SignalR reconnection attempts created elevated CPU load on our web servers, leading to degraded application performance.

Resolution
Our team increased the number of servers to handle the traffic spike. System performance has been restored to normal levels.

Next Steps
We'll continue monitoring for these connection patterns, and infrastructure scaling adjustments to prevent similar issues in the future and further optimise traffic. We apologise for any inconvenience and thank you for your patience.
Posted Nov 17, 2025 - 17:30 AEDT

Update

An additional server has been added to the pool while the investigation continues. CPU levels have returned to normal and performance has stabilised. We will continue to monitor the environment and provide further updates if required.
Posted Nov 17, 2025 - 10:06 AEDT

Investigating

We are currently experiencing high CPU utilisation on one of our Webset 1 hosts, which may cause performance issues for some users. Our team is investigating and actively working to restore normal performance.
Further updates will be provided as soon as they are available.
Posted Nov 17, 2025 - 10:03 AEDT
This incident affected: Website.